21.02.2016

Работа со строками, числами в циклах

Добро пожаловать в очередной урок школы обучения 1с. В сегодняшнем уроке - рассмотрим работу с некоторыми циклами.
Посмотрим как создаётся кнопка для формы.
А также поработаем с такими типами как строка и число.
Особенно интересно будет отсечение строки и выборка именно тех символов, которые нужны нам.

 Видеоразбор урока:





Элементы кода, рассмотренные в уроке


  

//Нетиповая /////////////////////////////
&НаКлиенте
Процедура ЗаполнитьПоОстатку(Команда)
	ИскомаяСтрока = Элементы.НадписьОстатокДенег.Заголовок;
	КоличествоСимволов = СтрДлина(ИскомаяСтрока);
	
	
	Для Счетчик=0 По КоличествоСимволов Цикл 
		ВыходимИзЦикла = Ложь;
		СимволИтерации = Сред(ИскомаяСтрока,Счетчик,1);
		
		Для Счетчик1 = 0 По 9 Цикл
			Если Строка(Счетчик1) = СимволИтерации Тогда
				ВыходимИзЦикла = Истина;
				ПозицияНачалаЧисла = Счетчик;
				Прервать;
			КонецЕсли;
			
		КонецЦикла;
		
		Если ВыходимИзЦикла Тогда 
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
	
	    		
		Если ПозицияНачалаЧисла >0 Тогда
			ОтсечемЛевуюЧасть = Прав(ИскомаяСтрока,КоличествоСимволов - ПозицияНачалаЧисла+1);
		КонецЕсли;
	
	
		
	ЧислоОстаток = Число(Лев(ОтсечемЛевуюЧасть,Найти(ОтсечемЛевуюЧасть,"руб.")-1)); 
	
	
	Элементы.Расходы.ТекущиеДанные.Сумма = ЧислоОстаток; 	
КонецПроцедуры



//Нетиповая////////////////////////






Возврат к списку

  • Facebook
  • Вконтакте